2024-05-28 01:42 AEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000322mercuryBugpublic2014-05-15 13:28
Assigned To 
Product Version 
Target VersionFixed in Version 
Summary0000322: mingw-w64 compiled program crashes
DescriptionMercury 14.01 branch

Cross-compiling with x86_64-w64-mingw32-gcc from Ubuntu
gcc version 4.6.3 (GCC)

For the given (small) test program:

asm_fast.gc CRASH
asm_jump.gc OK
reg.gc OK
none.gc OK
hlc.gc OK
TagsNo tags attached.
Attached Files
  • ? file icon bug.m (204 bytes) 2014-03-24 13:49




wangp (developer)

I also tried gcc 4.8.2 as built from the MXE project. The results for the same test case are:

asm_fast.gc OK
asm_jump.gc CRASH
reg.gc OK
none.gc OK

For a bigger program (prince) the results are:

asm_fast.gc CRASH
asm_jump.gc CRASH
reg.gc OK
none.gc OK

I'm not going to chase this any further now, but we should document the problem in the readme.


juliensf (administrator)

Have you tried the native Windows versions of GCC with this, or just the cross-compiler?


wangp (developer)

I'm pretty sure I did.


juliensf (administrator)

asm_fast.gc is ok with gcc 4.8.1 (mingw-builds package).

-Issue History
Date Modified Username Field Change
2014-03-24 13:49 wangp New Issue
2014-03-24 13:49 wangp File Added: bug.m
2014-03-25 11:03 wangp Note Added: 0000655
2014-05-13 15:34 juliensf Note Added: 0000683
2014-05-13 15:52 wangp Note Added: 0000684
2014-05-15 13:28 juliensf Note Added: 0000685
+Issue History