2017-12-11 16:39 AEDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000305mercuryBugpublic2016-10-04 21:24
Reportertantignac 
Assigned Tojuliensf 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
PlatformMacOSMac OS XOS Version10.9
Product Version 
Target VersionFixed in Version 
Summary0000305: Error during the build with clang
DescriptionI tried to configure and build Mercury with clang on my computer but it seems to fail, outputting:

------------------------------------------------
MMAKE_DIR=`pwd`/scripts scripts/mmake MMAKEFLAGS= all
/var/folders/bg/szy711t55qqgs0sssfxdj36h0000gn/T//mmake.ohG6jy:674: warning: undefined variable `DESTDIR'
scripts/Mmake.vars:674: warning: undefined variable `DESTDIR'
Mmake.common:135: warning: undefined variable `DESTDIR'
make[1]: *** No rule to make target `.README.in', needed by `README'. Stop.
make: *** [all] Error 2
------------------------------------------------

I attached the output of the two commands to configure and to build.

Would there is a way this issue could be solved?
Steps To Reproduce$ ./configure --with-cc=clang
$ make
TagsNo tags attached.
Attached Files
  • zip file icon logs.zip (4,174 bytes) 2013-12-03 00:02

-Relationships
+Relationships

-Notes

~0000584

juliensf (administrator)

Can you confirm that the hidden file .README.in is present in the top-level of the source
tree you have? It seems to be an issue with make; what version of that are you using?

~0000585

tantignac (reporter)

Thank you for your answer.

.README.in is in the directory from which I configure and build:

--------------------------------------
$ ./configure --with-cc=clang
[…]
$ ls -alrth .README.in
-rw-r--r--@ 1 thibaudantignac staff 5,1K 30 avr 2013 .README.in
--------------------------------------

The version of make is 3.81:

--------------------------------------
$ make -v
GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for i386-apple-darwin11.3.0
--------------------------------------

~0000586

juliensf (administrator)

I can't see anything obviously wrong in the configuration log. What happens if you comment out
the rule at Mmakefile:409

README: .README.in VERSION
        sed 's/@VERSION@/$(VERSION)/g' .README.in > README

This problem appears to be specific to OS X 10.9, every recent version of Mercury is working on 10.8.

~0000587

tantignac (reporter)

Thank you for the tip. Is is building now, hope it will ends without any further issue!

~0000588

juliensf (administrator)

Please let me know if it is successful or not -- incidentally, what version of Mercury are you
trying to install?

~0000589

tantignac (reporter)

Ok, I'll let you know whent it will be eventually finished.

Concerning the version, it is the 13.05.2 release.

~0000590

tantignac (reporter)

It worked!

-- Installation complete.

Thank you for your support!
+Notes

-Issue History
Date Modified Username Field Change
2013-12-03 00:02 tantignac New Issue
2013-12-03 00:02 tantignac File Added: logs.zip
2013-12-03 00:19 juliensf Note Added: 0000584
2013-12-03 00:36 tantignac Note Added: 0000585
2013-12-03 01:00 juliensf Note Added: 0000586
2013-12-03 01:07 tantignac Note Added: 0000587
2013-12-03 01:13 juliensf Note Added: 0000588
2013-12-03 01:15 tantignac Note Added: 0000589
2013-12-03 04:55 tantignac Note Added: 0000590
2016-10-04 21:24 juliensf Assigned To => juliensf
2016-10-04 21:24 juliensf Status new => closed
2016-10-04 21:24 juliensf Resolution open => no change required
+Issue History