2022-05-18 18:48 AEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000510mercuryBugpublic2022-01-25 22:15
Reporterzs 
Assigned Tozs 
PrioritynormalSeveritycrashReproducibilityalways
StatusfeedbackResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0000510: compiler crash due to missing type definition
DescriptionThe valid/bug510 test case (which I added and committed just now) causes a compiler crash.
It occurs when the compiler tries to look up the definition of the sparse_bitset type,
but does not find it, due to it being hidden behind module abstraction barriers.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001162

zs (developer)

Some change in the last 18 or so months has fixed this test case,
since it does not cause a compiler crash anymore.

~0001163

zs (developer)

The crash is still present in MLDS grades.
+Notes

-Issue History
Date Modified Username Field Change
2020-06-19 17:33 zs New Issue
2020-06-19 17:33 zs Status new => assigned
2020-06-19 17:33 zs Assigned To => zs
2022-01-25 03:55 zs Status assigned => resolved
2022-01-25 03:55 zs Resolution open => fixed
2022-01-25 03:55 zs Note Added: 0001162
2022-01-25 22:15 zs Status resolved => feedback
2022-01-25 22:15 zs Resolution fixed => reopened
2022-01-25 22:15 zs Note Added: 0001163
+Issue History